Расскажите друзьям о статье...
Share on VK
VK
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter


Запретить какой-либо ресурс можно несколькими вариантами, каждый вариант имеет свои плюсы и минусы, есть еще множество вариантов как заблочить сайт на Микротик, кроме описанных в данной статье.

1.1 Блокировка сайтов по ip адресу – 1.

Перейдите в Terminal и введите команды, где в поле address нужно указать сайт, к которому будет блокирован доступ:

/ip firewall address-list add list=Block_sites address=ithelp21.ru disabled=no
/ip firewall address-list add list=Block_sites address=pikabu.ru disabled=no
/ip firewall filter add chain=forward src-address-list=Block_sites protocol=tcp action=reject reject-with=tcp-reset disabled=no

Обязательное условие.
В IP – Firewall – Filter Rules созданное правило должно быть выше остальных.

1.2 Блокировка сайтов по ip адресу – 2.

Еще один способ блокировки по IP-адресу сайта заключается в добавлении ip-сайта в адрес лист, вместо доменного имени.

Что бы узнать ip сайта, нужно в Terminale или командной строке ввести ping ithelp21.ru или nslookup ithelp21.ru, после чего отобразится нужный нам адрес.

/ip firewall address-list add list=Block_sites address=31.20.13.34 disabled=no
/ip firewall address-list add list=Block_sites address=31.20.13.35 disabled=no
/ip firewall filter add chain=forward src-address-list=Block_sites protocol=tcp action=reject reject-with=tcp-reset disabled=no

Как и в первом случае, правило должно быть выше остальных в IP – Firewall – Filter Rules.

2. Блокировка сайтов через Layer7-protocol.

Последовательность такая: Создаем layer7-protocol с блокируемым ресурсом, маркируем соединения на указанный ресурс, далее маркируем пакеты с данного соединения и режем все через firewall.

/ip firewall layer7-protocol
add name=youtube regexp="^.+(youtube).*\$"

/ip firewall mangle
add action=mark-connection chain=prerouting protocol=udp dst-port=53 connection-mark=no-mark layer7-protocol=youtube new-connection-mark=BLOCK_connection_youtube passthrough=yes
add action=mark-packet chain=prerouting connection-mark=BLOCK_connection_youtube new-packet-mark=BLOCK_youtube_packet

/ip firewall filter
add action=drop chain=forward packet-mark=BLOCK_youtube_packet
add action=drop chain=input packet-mark=BLOCK_youtube_packet

В некоторых случаях требуется перезагрузка роутера, что бы изменения вступили в силу.

/system reboot
3. Блокировка с помощью DNS.

Это случай подразумевает, что на ваших ПК в роли DNS указан IP роутера,а не провайдера, то есть чаще всего 192.168.0.1.

/ip dns static add name="ithelp21.ru" address=127.0.0.1
/ip dns static add name="pikabu.ru" address=127.0.0.1
4. И еще один способ в одну строчку.

Указываем content= адрес сервера.

/ip firewall filter
add action=reject chain=forward content=ithelp21.ru protocol=tcp reject-with=tcp-reset

Пишите в комментариях, каким способом вы воспользовались, возможно использовали какой-то другой, не описанный в статье.

Расскажите друзьям о статье...
Share on VK
VK
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter

One thought on “Блокировка сайтов на Mirkotik (4 способа).

  1. Прошу написать как заблокировать вредоносные и порно сайты на микротик. Пробоал разные способы не помогает. Напишите статью, буду благодарен. Спасибо

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.