Расскажите друзьям о статье...
Share on VK
VK
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter

Протокол OSPF является одним из протоколов динамической маршрутизации. При выборе наилучшего маршрута он смотрит на скорость канала, а не наименьшее расстояние, как это делает, например протокол RIP. Получается, что маршрут от одной точки до другой может быть очень длинным, но в то же время он будет самым быстрым.
Если сеть становится большой, то ее обычно делят на зоны (Area), для того, что бы каждый маршрутизатор не хранил у себя в базу огромную информацию о других маршрутизаторах, и не нагружал память и процессор.

Пройдемся по зонам (Area):
Backbone – магистральная, всегда Area 0 . Выполняет роль маршрутизации между зонами.
Standard – стандартная. Может содержать пограничные маршрутизаторы зоны ABR и пограничные маршрутизаторы автономной системы ASBR, то есть может подключаться к другим автономным системам.
Stub – тупиковая. Маршрут к внешним сетям заменен на маршрут по умолчанию. Не может иметь ASBR маршрутизатор – не подключается к другим автономным сетям. Не принимает анонсы о внешних сетях всей автономной зоны, однако принимает анонсы о других зонах
Totally Stub – абсолютно тупиковая. Такая же сеть, как и Stub, но еще не принимает анонсы о других зонах. Маршруты к другим зонам заменены на маршрут по умолчанию.
Not-So-Stubby-Area (NSSA) – частично тупиковая сеть.Такая же сеть, как и Stub, но еще может иметь ASBR маршрутизатор.
Totally NSSA. “Усиление” NSSA, кроме того маршруты к другим зонам заменены на маршрут по умолчанию.

ABR

Маршрутизаторы BR, ABR, ASBR требуют большие мощности и пропускную способность, так как они оперируют с большими потоками данных.
Следует выделить специальные маршрутизаторы, играющие определенную роль при разделении на зоны:
Магистральный маршрутизатор (Backbone router, BR) – находится только в зоне 0.
Пограничный маршрутизатор (Area Border Router, ABR) – находится на стыке 2-х и более зон.
Внутренний маршрутизатор (Internal Router) – маршрутизатор внутри зоны.
Маршрутизатор AS Boundary router, ASBR – подключается на стыке разных автономных систем

Настроим для примера схему из трех маршрутизаторов по протоколу OSPF.

OSPF

Router1

Router1#conf t
Router1(config)#interface gigabitEthernet 0/0
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config)#interface gigabitEthernet 0/2
Router1(config-if)#ip address 50.0.0.10 255.255.255.0
Router1(config-if)#no shutdown
Router1(config)#interface gigabitEthernet 0/1
Router1(config-if)#ip address 100.0.0.10 255.255.255.0
Router1(config-if)#no shutdown

Router2

Router2#conf t
Router2(config)#interface gigabitEthernet 0/0
Router2(config-if)#ip address 192.168.2.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config)#interface gigabitEthernet 0/1
Router2(config-if)#ip address 100.0.0.20 255.255.255.0
Router2(config-if)#no shutdown
Router2(config)#interface gigabitEthernet 0/2
Router2(config-if)#ip address 10.0.0.20 255.255.255.0
Router2(config-if)#no shutdown

Router3

Router3#conf t
Router3(config)#interface gigabitEthernet 0/0
Router3(config-if)#ip address 192.168.3.1 255.255.255.0
Router3(config-if)#no shutdown
Router3(config)#interface gigabitEthernet 0/1
Router3(config-if)#ip address 50.0.0.20 255.255.255.0
Router3(config-if)#no shutdown
Router3(config)#interface gigabitEthernet 0/2
Router3(config-if)#ip address 10.0.0.10 255.255.255.0
Router3(config-if)#no shutdown

Router1 настройка OSPF

Router1#conf t
Router1(config)#router ospf 1
network 50.0.0.0 0.0.0.255 area 0
network 100.0.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
Router1#conf t
Router1(config)#router ospf 1
Router1(config-router)#area 0 authentication
Router1(config)#interface gigabitEthernet 0/1
Router1(config-if)#ip ospf authentication
Router1(config-if)#ip ospf authentication-key ithelp21
Router1(config)#interface gigabitEthernet 0/2
Router1(config-if)#ip ospf authentication
Router1(config-if)#ip ospf authentication-key ithelp21

Router2 настройка OSPF

Router2#conf t
Router2(config)#router ospf 1
network 10.0.0.0 0.0.0.255 area 0
network 100.0.0.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
Router2#conf t
Router2(config)#router ospf 1
Router2(config-router)#area 0 authentication
Router2(config)#interface gigabitEthernet 0/1
Router2(config-if)#ip ospf authentication
Router2(config-if)#ip ospf authentication-key ithelp21
Router2(config)#interface gigabitEthernet 0/2
Router2(config-if)#ip ospf authentication
Router2(config-if)#ip ospf authentication-key ithelp21

Router3 настройка OSPF

Router3#conf t
Router3(config)#router ospf 1
network 10.0.0.0 0.0.0.255 area 0
network 50.0.0.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
Router3#conf t
Router3(config)#router ospf 1
Router3(config-router)#area 0 authentication
Router3(config)#interface gigabitEthernet 0/1
Router3(config-if)#ip ospf authentication
Router3(config-if)#ip ospf authentication-key ithelp21
Router3(config)#interface gigabitEthernet 0/2
Router3(config-if)#ip ospf authentication
Router3(config-if)#ip ospf authentication-key ithelp21
Полезные команды OSPF.

show ip route – посмотреть таблицу маршрутизации, где О – OSPF протокол.
show ip protocols – настройки и состояние протокола.
show ip ospf database – содержит информацию обо всех маршрутизаторах своей зоны и активных интерфейсах этих маршрутизаторах. Все маршрутизаторы одной зоны имеют одинаковую таблицу.
show ip ospf interface – посмотреть интерфейсы на которых используется OSPF.
show ip ospf neighbor – посмотреть соседей OSPF.

Команды для дебага OSPF:

debug ip ospf adj;
no debug ip ospf adj;
debug ip ospf events;
no debug ip ospf events;
Настройка аутентификации.
Router3(config)#router ospf 1
Router3(config-router)#area 0 authentication

1) Пароль открытым текстом

Router(config-if)# ip ospf authentication
Router(config-if)# ip ospf authentication-key пароль

2) С помощью MD5

Router(config-if)# ip ospf authentication message-digest
Router(config-if)# ip ospf message-digest-key номер ключа md5 пароль

Глобальная настройка аутентификации:

Router(config)# router ospf номер процесса
Router(config-router)# area номер зоны authentication message-digest

Пароли дложны быть на каждом интерфейсе:

Router(config-if)# ip ospf message-digest-key номер ключа md5 пароль
Расскажите друзьям о статье...
Share on VK
VK
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.