mtk-min
Расскажите друзьям о статье...
Share on VK
VK
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter

В этой статье разберем настройку VLAN на Mikrotik.
Для примера у нас есть два Mikrotik, первый будет DHCP-Server, второй будет DHCP- клиент.
Порты Eth2 в MTK1 и Eth1 в MTK2, которые будут участвовать в соединение роутеров, мы завернем в 333 VLAN и tag.

В данной схеме первого способа будем использовать Bridge на тот случай, если кроме порта Eth2 в MTK1 мы захотим отдавать 333 VLAN в другие порты Eth3-Eth5, в этом случае нам нужно будет добавить данные интерфейсы созданный Bridge c Eth2.

Если вам нужно просто соединить два устройства между собой портами смотрящими друг на друга через VLAN 333, то переходите ко второму способу.

Первый способ соединения используя VLAN  и BRIDGE.

Начнем настройку с первого устройства MTK1.

Настройка VLAN MTK1 DHCP_Server

1. Создаем Bridge. Bridge – “+” – BridgeVlan_333.
Создаем Vlan в который будем оборачивать порт. Interfaces – VLAN – “+”.
При создании VLAN указываем порт, на который будем его вешать.

Name: Vlan_333;
VLAN ID: 333;
Interface: Ethernet_2_vlan333;

2. Переходим Bridge – Ports – “+”.
Созданный Vlan_333 поместим в Bridge Bridge_vlan333.

Interface: vlan_333;
Bridge: bridge_vlan333;

3. Направим DHCP сервер на созданный Bridge. Ip – DHCP Server – Dhcp_vlan333.

Name: dhcp_vlan333;
Interface: bridge_vlan333;
Address Pool: pool_vlan333;

4.Переходим  IP – Adresses.
Выбираем или добавляем адресацию DHCP сервера, которую выбрали выше в бридж с vlan333.

Adresses: 192.168.100.1/24;
Network: 192.168.100.0;
Interface: bridge_vlan333;

Переходим к настройке MTK2 – DHCP _client.

1. Создаем Vlan 333 в Interfaces – VLAN – “+”.

Name: Vlan333;
VLAN ID: 333;
Interface: Ethetnet1_WAN;

2. Переходим в Bridge – “+”.
Создаем Bridge333_vlan.

3. На вкладке Bridge – Ports добавляем Bridge Port.

Interface: vlan333;
Bridge: bridge333_vlan;

4. Переходим в IP – DHCP Clinet и указываем интерфейс для DHCP client – vlan333.
Interface: bridge_vlan333;

Если у вас статика, то в разделе Ip - addresses для указанного сетевого адреса указываем интерфейс bridge333_vlan.

5. В NAT Добавим маскарад. IP – Firewall – NAT.
Chain: Srcnat.
Out. Interface: bridge_vlan333;
Action: masquerade.

На этом настройка закончена, порты находятся в tag Vlan 333.
Если вам не нужно более проще подключить устройства с VLAN без BRIDGE – переходите ко второму способу.

Второй способ соединения используя VLAN  без использования BRIDGE.

Здесь для разнообразия сделаем второй Mikrotik со статическим адресом 192.168.100.100, вместо DHCP – клиента, как в первом случае.

Первый Mikrotik настройка.
Вешаем Vlan 333 на порт Eth2 Микротик №1, и отдаем адресацию через vlan333.

/interface vlan add interface=ether2 name=vlan333 vlan-id=333
/ip address add address=192.168.100.1/24 interface=vlan333 network=192.168.100.0
/add address-pool=pool_vlan100 disabled=no interface=vlan333 lease-time=1w name=dhcp_vlan333
/ip pool add name=pool_vlan100 ranges=192.168.100.5-192.168.100.239
/ip dhcp-server add address-pool=pool_vlan333 disabled=no interface=vlan333 lease-time=1w name=dhcp_vlan333

Второй Mikrotik, вместо dhcp-client ему настраиваем статический адрес 192.168.100.100 во vlan 333 и прописываем маршрут по-умолчанию.

/interface vlan add interface=ether1_WAN name=vlan333 vlan-id=333
/add address=192.168.100.100/24 interface=vlan333 network=192.168.100.0
/ip route add distance=1 gateway=192.168.100.1

На этом настройка двух вариантов подключения через VLAN завершена.

Расскажите друзьям о статье...
Share on VK
VK
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.